Wire Reference - Patch Window

The Wire software and documentation is Copyright 2000-2008 by SoftSynth.com, All Rights Reserved

Click here for the Wire Documentation Home Page
Synthesis Modules - list of available modules

File Menu

Open Patch...

This will load a patch as a subpatch and open its editor window.


Save the current patch in the same file it was loaded from, or the last file it was saved to.

Save As...

Save the patch in a new file with a different name. A "file save" dialog will be displayed. Patches are stored in XML format so the files should have an ".xml" suffix.

Export as Java Source...

Exports the current patch as Java source code. This code may be compiled and used in other JSyn programs besides Wire. It can also be imported back into Wire as a SynthCircuit.

Note that the Export feature is only available to registered JSyn developers. It is disabled in the demo version. Click here to learn about registering your JSyn SDK.

Edit Menu


Copy any modules which are currently selected to the paste buffer then deletes them.


Copy any modules which are currently selected to the paste buffer.


Copy any modules in the paste buffer to the current Patch window.


Delete any modules which are currently selected.

View Menu

Main Window

Make the Wire Main Window visible.


Patches can be nested, one inside the other. This item will cause the patch that contains the current patch to be displayed.

Add Menu

This menu is used to add modules or patches to the current patch.

Synthesis Modules - list of available modules

Empty Patch

Create an empty patch inside this patch. Double click on the top of the new patch module to open up its editor window.

SynthNote Patch

Create a patch that has an output port named "output", and input ports named "frequency" and "amplitude". This is convenient because this is a common configuration that corresponds to a JSyn SynthNote. You can create the same thing yourself starting with an Empty Patch.

Patch from File...

Load an existing patch from a file. Patches are stored in XML format.

Circuit by Name...

Load a compiled SynthCircuit class into Wire. Subclasses, for example a SynthNote, can also be loaded. The class will be examined and jacks will be created for its SynthPorts automatically. So if a SynthNote has a frequency port, a frequency jack will be created.

You will be prompted with a Text Field. Enter the full class name including the package, for example "patches.MyCoolPatch".

Note that once a class has been loaded, it cannot be reloaded. So if you recompile the class, you must exit Wire and then rerun Wire in order to reload the modified class.

Patch Editing

Connecting and Disconnecting Modules

To connect two modules, click down on an output port. Hold the mouse down as you drag to an input port and release the mouse.

To break a connection, click on the input port, drag the connection off and let go.

Selecting Modules

You can select a module by clicking on the top of the module. You can select multiple modules by hold down the SHIFT key while clicking.
You can also click in the background of a patch window and drag out a rectange. Any modules contained within the rectangle will be selected.